Help

Bat To Exe Converter - Help

Index

1 - Program description

1.1 Description
1.2 Usage
1.3 Options
1.4 Commandline
1.5 Environment variables
1.6 System requirements

2 - License

2.1 License
2.2 Miscelleanous

3 - Contact

3.1 Author
3.2 Website
3.3 Email

Description

Bat To Exe Converter converts BATCH (.bat) script files to the EXE (.exe) format.

Usage

Select a batch file and the save path.
Set your preferred options.
Click on the button 'Compile'

Options

Visible application | Create a visible application with a console window
Invisible application | Create an invisible application without a console window
32 Bit | Create a 32 Bit application
64 Bit | Create a 64 Bit application
Current directory | Use the current directory on execution
Temporary directory | Use the temporary directory on execution
Delete at exit | Delete the temporary files at exit
Do not delete | Do not delete the temporary files
Encrypt the program | Encrypt the program with a password
Administrator Manifest | Add an administrator manifest to the program
Overwrite existing files | Overwrite existing files
Include | Include additional files to the program
Icon | Include an icon to the program
Version information | Include version information to the program
Editor | Shows and edits the content of your batch file
Compress the exe using UPX | Compress the exe using UPX

Commandline

-bat [filename] | The bat file that you want to convert
-save [filename] | The output filename of your exe
-icon [filename] | The icon file of your application
-invisible | Create an invisible application
-x64 | Create a 64 Bit application
-temp | Use the temporary directory on execution
-nodelete | Do not delete the temporary files
-encrypt [Password] | Encrypt the program with a password
-admin | Add an administrator manifest to the program
-overwrite | Overwrite existing files
-include [filename] | Include an additional file to the program
-fileversion [String] | File version number
-productversion [String] | Product version number
-company [String] | Company name
-productname [String] | Product name
-internalname [String] | Internal name
-description [String] | Product description
-copyright [String] | Copyright
-upx | Compress the exe using UPX
-b2edecompile | Start the decompiler - Converts exe back to bat
-b2epass [Password] | Decrypt exe file. Input box will be suppressed.

Examples

Bat_To_Exe_Converter.exe -bat mybatfile.bat -save myprogram.exe -icon myicon

myprogram.exe -b2epass password

myprogram.exe -b2edecompile

Environment variables

These environment variables are automatically set at the start of your converted program

b2eincfile(number) | Returns, if available, the include filename
b2eincfilecount | Returns the number of files included
b2eincfilepath | Returns the include file path
b2eprogramname | Returns the full path name of your executable
b2eprogramfilename | Returns the file name of your executable
b2eprogrampathname | Returns the directory name of your executable
b2eprogramshortname | Returns the short DOS (8.3) path name of your executable

System requirements

Windows 2000 or higher

License

License Agreement

Copyright (c) 2015 Fatih Kodak

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.

Miscelleanous

This program uses: GoLink GoRC Scintilla UPX

The Scintilla license can be viewed here

Translators

Brazilian portuguese : Mauri Azevedo da Costa

Chinese : 大眼仔~旭

Dutch : Kaspar RAVE

French : Riki

Hungarian : Zityi's Translator Team

Italian : Gianluca Mesil

Persian : ویژوال ای اف ایکس

Russian : Александр Садовский/Валерий Романовский

Swedish : Åke Engelbrektson

Turkish : Inanç Özkurt

Contact

Author:
Fatih Kodak
Website:
www.f2ko.de
Email:
webmaster@f2ko.de


Hilfe

Bat To Exe Converter - Hilfe

Index

1 - Programmbeschreibung

1.1 Beschreibung
1.2 Verwendung
1.3 Optionen
1.4 Kommandozeile
1.5 Umgebungsvariablen
1.6 Systemvorraussetzungen

2 - Lizenz

2.1 Lizenz
2.2 Sonstiges

3 - Kontakt

3.1 Author
3.2 Webseite
3.3 Email

Beschreibung

Bat To Exe Converter wandelt BATCH (.bat) Dateien in das EXE (.exe) Format um.

Verwendung

Wählen Sie eine Bat Datei zum Öffnen und den Pfad zum Speichern aus.
Nehmen Sie Ihre gewünschten Einstellungen vor.
Klicken Sie auf 'Kompilieren'

Optionen

Sichtbares Programm | Erstellt ein sichtbares Programm mit einem Konsolefenster
Unsichtbares Programm | Erstellt ein unsichtbares Programm ohne Konsolefenster
32 Bit | Erstellt ein 32 Bit Programm
64 Bit | Erstellt ein 64 Bit Programm
Aktuelles Arbeitsverzeichnis | Führt das erstellte Programm im aktuellen Verzeichnis aus
Temporärer Ordner | Führt das erstellte Programm im Temp Verzeichnis aus
Beim Beenden löschen | Löscht alle temporären Dateien am Ende der Ausführung
Nicht löschen | Löscht keine temporären Dateien
Programm verschlüsseln | Verschlüsselt das Programm mit einem Passwort
Administrator Manifest | Fügt dem Programm ein Administrator Manifest hinzu
Dateien überschreiben | Überschreibt bereits vorhande Dateien
Einfügen | Fügt Dateien in das Programm ein
Icon | Bindet ein Icon in das Programm ein
Versionsinformationen | Bindet Versionsinformationen in das Programm ein
Editor | Zeigt und ändert den Inhalt der Batch Datei
Mit UPX komprimieren | Komprimiert das Programm mit UPX

Kommandozeile

-bat [Dateiname] | Die zu konvertierende Bat Datei
-save [Dateiname] | Name zum Speichern der Exe Datei
-icon [Dateiname] | Name der Icondatei
-invisible | Erstellt eine unsichtbare Anwendung
-x64 | Erstellt eine 64 Bit Anwendung
-temp | Führt das erstellte Programm im Temp Verzeichnis aus
-nodelete | Löscht die temporären Dateien am Ende der Ausführung nicht
-encrypt [Passwort] | Verschlüsselt das Programm mit einem Passwort
-admin | Fügt dem Programm ein Administrator Manifest hinzu
-overwrite | Überschreibt bereits vorhandene Dateien
-include [Dateiname] | Bindet eine Datei in das Programm ein
-fileversion [String] | Nummer der Dateiversion
-productversion [String] | Nummer der Produktversion
-company [String] | Name der Firma
-productname [String] | Name des Produktes
-internalname [String] | Interner Name des Produktes
-description [String] | Produktbeschreibung
-copyright [String] | Urheberrecht
-upx | Komprimiert das Programm mit UPX
-b2edecompile | Öffnet den Decompiler - Konvertiert die Exe wieder zur Bat
-b2epass [Passwort] | Entschlüsselt die konvertierte Datei ohne manuelle Eingabeaufforderung

Beispiele

Bat_To_Exe_Converter.exe -bat mybatfile.bat -save myprogram.exe -icon myicon

myprogram.exe -b2epass password

myprogram.exe -b2edecompile

Umgebungsvariablen

Beim Start einer konvertierten Exe werden automatisch folgende Umgebungsvariablen gesetzt

b2eincfile(nummer) | Zeigt, falls vorhanden, den Namen der eingebunden Datei an
b2eincfilecount | Zeigt die Anzahl der eingebundenen Dateien an
b2eincfilepath | Zeigt an, in welchem Pfad, sich die eingebundenen Dateien befinden
b2eprogramname | Zeigt den vollständigen Pfad der Exe Datei an
b2eprogramfilename | Zeigt den Namen der Exe Datei an
b2eprogrampathname | Zeigt das Verzeichnis der Exe Datei an
b2eprogramshortname | Zeigt den vollständigen Pfad der Exe Datei als kurzen Dos 8.3 Namen an

Systemvorraussetzungen

Windows 2000 oder höher

Lizenz (englischer Text)

License Agreement

Copyright (c) 2015 Fatih Kodak

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.

Sonstiges

Das Programm verwendet: GoLink GoRC Scintilla UPX

Die Scintilla Lizenz kann hier eingesehen werden.

Übersetzer

Brasilianisches Portugiesisch : Mauri Azevedo da Costa

Chinesisch : 大眼仔~旭

Französisch : Riki

Holländisch : Kaspar RAVE

Italienisch : Gianluca Mesil

Persisch : ویژوال ای اف ایکس

Russisch : Александр Садовский/Валерий Романовский

Schwedisch : Åke Engelbrektson

Türkisch : Inanç Özkurt

Ungarisch : Zityi's Translator Team

Kontakt

Author :
Fatih Kodak
Webseite:
www.f2ko.de
Email:
webmaster@f2ko.de


Help

Extended commands

Bat To Exe Converter has some extended commands, that are not normally available in batch files.
You must use the prefix %extd% to call the extended commands.

Ascii

Description

Returns the ASCII value of the specified character

Syntax

%extd% /ascii character

Example

%extd% /ascii A ; (This will return 65)

Return value

Returns the result in the variable %result%

BrowseForFile

Description

This will open a dialog box to browse for a file.

Syntax

%extd% /browseforfile title defaultfile pattern position

Example

%extd% /browseforfile "Browse for a file" "" "EXE (*.exe)|*.exe|BAT (*.bat)|*.bat" 1

Return value

Returns the result in the variable %result%

BrowseForFolder

Description

This will open a dialog box to browse for a folder.

Syntax

%extd% /browseforfolder title startpath

Example

%extd% /browseforfolder "Browse for a folder" C:\

Return value

Returns the result in the variable %result%

Char

Description

Returns the character of the specified ASCII value

Syntax

%extd% /char value

Example

%extd% /char 65 ; (This will return A)

Return value

Returns the result in the variable %result%

CloseWindow

Description

Close the specified window

Syntax

%extd% /closewindow windowname

Example

%extd% /closewindow Calculator; (This will close calculator)

Return value

This command has no return value

CRC32

Description

Calculate the CRC32 checksum of the given file

Syntax

%extd% /crc32 filename

Example

%extd% /crc32 myfile.txt; (This will calculate the CRC32 checksum of "myfile.txt")

Return value

Returns the result in the variable %result%

Download

Description

Download a file from the given URL

Syntax

%extd% /download url filename

Example

%extd% /download http://www.f2ko.de/downloads/Bat_To_Exe_Converter.zip Bat_To_Exe_Converter.zip

Return value

Returns the result (a value unequal to zero on success) in the variable %result%

GetClipboardText

Description

Return the last pasted text in the clipboard

Syntax

%extd% /getclipboardtext

Example

%extd% /getclipboardtext

Return value

Returns the result in the variable %result%

HideWindow

Description

Hide the specified window

Syntax

%extd% /hidewindow windowname

Example

%extd% /hidewindow Calculator ; (This will hide calculator)

Return value

This command has no return value

Input

Description

Read a line from the console input

Syntax

%extd% /input

Example

%extd% /input

Return value

Returns the result in the variable %result%

InputBox

Description

Open an input box

Syntax

%extd% /inputbox title message default

Example

%extd% /inputbox Title "Enter the text below" "I'm the default input"

Return value

Returns the result in the variable %result%

Is64Bit

Description

Determine whether your computer is running a 32-bit version or 64-bit version of Windows

Syntax

%extd% /is64bit

Example

%extd% /is64bit

Return value

Returns the result (1 = 64Bit) in the variable %result%

Left

Description

Extract a substring of a string from the left side

Syntax

%extd% /left string length

Example

%extd% /left String 3 ; (This will return "Str")

Return value

Returns the result in the variable %result%

LowerCase

Description

Returns the given string converted into lower case characters

Syntax

%extd% /lowercase string

Example

%extd% /lowercase STRING ; (This will return "string")

Return value

Returns the result in the variable %result%

MaskedInput

Description

Read a line from the console, while hiding the input

Syntax

%extd% /maskedinput

Example

%extd% /maskedinput

Return value

Returns the result in the variable %result%

MaximizeWindow

Description

Maximize the specified window

Syntax

%extd% /maximizewindow windowname

Example

%extd% /maximizewindow Calculator

Return value

This command has no return value

MD5

Description

Return the MD5 fingerprint of the given file

Syntax

%extd% /md5 filename

Example

%extd% /md5 example.txt

Return value

Returns the result in the variable %result%

Mid

Description

Extract a substring from a string at the specified position

Syntax

%extd% /mid string position

Example

%extd% /mid String 3 ; (This will return "ring")

Return value

Returns the result in the variable %result%

MessageBox

Description

Display a messagebox

Syntax

%extd% /messagebox titel text flag

Example

%extd% /messagebox Error Message 16

Return value

Returns the result in the variable %result%

MinimizeWindow

Description

Minimize the specified window

Syntax

%extd% /minimizewindow windowname

Example

%extd% /minimizewindow Calculator

Return value

This command has no return value

MouseClick

Description

Simulate mouse clicks

Syntax

%extd% /mouseclick value

Values

-lc : left click
-rc : right click
-ldc : left double click
-rdc : right double click

Example

%extd% /mouseclick -rc ; (This will simulate a right click)

Return value

This command has no return value

Random

Description

Generate a random number

Syntax

%extd% /random maximum

Example

%extd% /random 1000

Return value

Returns the result in the variable %result%

RC4

Description

Crypt the given file using the RC4 alrorithm

Syntax

%extd% /rc4 source destination key

Example

%extd% /rc4 file.txt file.rc4 samplekey

Return value

This command has no return value

ResizeWindow

Description

Resize the specified window

Syntax

%extd% /resizewindow windowname x y width height

Example

%extd% /resizewindow Calculator 0 0 100 100

Return value

This command has no return value

Right

Description

Extract a substring of a string from the right side

Syntax

%extd% /right string length

Example

%extd% /right String 3 ; (This will return "Str")

Return value

Returns the result in the variable %result%

SaveFileDialog

Description

This will open a dialog box to save a file.

Syntax

%extd% /savefiledialog title defaultfile pattern

Example

%extd% /savefiledialog "Save file as" "" "All Files (*.*)|*.*"

Return value

Returns the result in the variable %result%

SendKeys

Description

Simulates text input.

Syntax

%extd% /sendkeys text

Example

%extd% /sendkeys text

Return value

This command has no return value

SetForegroundWindow

Description

Bring the specified window to the foreground

Syntax

%extd% /setforegroundwindow windowname

Example

%extd% /setforegroundwindow Calculator

Return value

This command has no return value

SHA1

Description

Return the SHA1 fingerprint of the given file

Syntax

%extd% /sha1 filename

Example

%extd% /sha1 example.txt

Return value

Returns the result in the variable %result%

ShowWindow

Description

Show the previously hidden window again

Syntax

%extd% /showwindow windowname

Example

%extd% /showwindow Calculator

Return value

This command has no return value

SetClipboardText

Description

Stores the given string into the clipboard

Syntax

%extd% /setclipboardtext text

Example

%extd% /setclipboardtext text

Return value

This command has no return value

SetCursor

Description

Moves the cursor to the specified screen coordinates

Syntax

%extd% /setcursor x y

Example

%extd% /setcursor 100 100

Return value

This command has no return value

Sleep

Description

Wait the specified number of milliseconds

Syntax

%extd% /sleep milliseconds

Example

%extd% /sleep 2000

Return value

This command has no return value

StrCount

Description

Counts the number of times a substring occurs in a string

Syntax

%extd% /strcount string stringtocount

Example

%extd% /strcount "This is the sample string" is

Return value

Returns the result in the variable %result%

StrPos

Description

Search for the first occurrence of substring inside a string

Syntax

%extd% /strpos string searchstring

Example

%extd% /strpos "a sample string" "sample"

Return value

Returns the result in the variable %result%

StrReplace

Description

Replace some characters with some other characters in a string

Syntax

%extd% /strreplace string searchstring replacestring

Example

%extd% /strreplace "a sample string" sample replaced

Return value

Returns the result in the variable %result%

StrRev

Description

Reverse a string

Syntax

%extd% /strrev string

Example

%extd% /strrev "string to reverse"

Return value

Returns the result in the variable %result%

Tempfile

Description

Creates a name for a temporary file

Syntax

%extd% /tempfile directory

Example

%extd% /tempfile %temp%

Return value

Returns the result in the variable %result%

Trim

Description

Removes all the spaces at the beginning and at the end of the string

Syntax

%extd% /trim string

Example

%extd% /trim " test "

Return value

Returns the result in the variable %result%

UpperCase

Description

Returns the given string converted into upper case characters

Syntax

%extd% /uppercase string

Example

%extd% /uppercase string ; (This will return "STRING")

Return value

Returns the result in the variable %result%

UnZip

Description

Extract the contents of the specified Zip archive to the destination folder

Syntax

%extd% /unzip zipfile destination

Example

%extd% /unzip sample.zip c:\

Return value

This command has no return value

WindowOnTop

Description

Make the window stay on top

Syntax

%extd% /windowontop windowname

Example

%extd% /windowontop Calculator

Return value

This command has no return value

Zip

Description

Add and compress the file/folder to the specified Zip archive

Syntax

%extd% /zip filetozip zipfile

Example

%extd% /zip sample.txt packed.zip

Return value

This command has no return value


License for Scintilla and SciTE

Copyright 1998-2002 by Neil Hodgson <neilh@scintilla.org>

All Rights Reserved

Permission to use, copy, modify, and distribute this software and its
documentation for any purpose and without fee is hereby granted,
provided that the above copyright notice appear in all copies and that
both that copyright notice and this permission notice appear in
supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS
SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY
AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY
SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE
OR PERFORMANCE OF THIS SOFTWARE.